Search found 586 matches

by Simon_Admin
Tue Jan 16, 2018 9:02 am
Forum: Technical Questions & Answers
Topic: Pinto - motocraft electronic ignition
Replies: 10
Views: 154

Re: Pinto - motocraft electronic ignition

You should be able to go backwards as there was no changes to the block.
A trusty DGV/DGAV from either an early Sierra or Cortina / Capri with matching manifold plus the distributor and coil.
If you can find one the ford Inductive ignition system is the best "oem" solution.
by Simon_Admin
Mon Jan 15, 2018 1:13 pm
Forum: Technical Questions & Answers
Topic: Pinto - motocraft electronic ignition
Replies: 10
Views: 154

Re: Pinto - motocraft electronic ignition

Hi James, Is the pipe connected to the carb near the throttle ? I believe there was rare ECU based ignition that had a map sensor in the ECU which calculated the advance based on engine speed and load rather than using the mechanical / vaccum advance. From memory it was the "ESC" system that was fur...
by Simon_Admin
Wed Dec 20, 2017 11:57 am
Forum: Technical Questions & Answers
Topic: 1600 OHV - dipstick and oil separator unit
Replies: 3
Views: 67

Re: 1600 OHV - dipstick and oil separator unit

Doesn't sound good if it's leaking from the dipstick, PCV valve & rear crank seal - it's not suffering from excessive crankcase pressure due to worn rings / bores is it ?
by Simon_Admin
Wed Dec 20, 2017 11:54 am
Forum: Technical Questions & Answers
Topic: 1600 OHV with Type B gearbox - clutch cable?
Replies: 6
Views: 96

Re: 1600 OHV with Type B gearbox - clutch cable?

From memory (it was a long time ago) the RS2000 cable is longer, I seem to remember there is something written in the build manual about the clutch cable ??
by Simon_Admin
Wed Dec 20, 2017 11:52 am
Forum: Technical Questions & Answers
Topic: Early starts - anyone got "Hot start"
Replies: 9
Views: 148

Re: Early starts - anyone got "Hot start"

With a lucas "king of Darkness" injection system made out of a conglomeration of Jaguar & rover parts with a Self built and tuned Megajolt ignition ECU salved in place of the Hopeless (sorry opus) ignition system I wouldn't say it's boring lol - it's just a case of gaining an understanding of what y...
by Simon_Admin
Mon Dec 18, 2017 10:07 am
Forum: Technical Questions & Answers
Topic: Early starts - anyone got "Hot start"
Replies: 9
Views: 148

Re: Early starts - anyone got "Hot start"

Like I said I don't miss all this clockwork stuff.... :D
by Simon_Admin
Thu Dec 14, 2017 3:19 pm
Forum: Technical Questions & Answers
Topic: Early starts - anyone got "Hot start"
Replies: 9
Views: 148

Re: Early starts - anyone got "Hot start"

Carb icing in my (bitter) experience occurs after the engine has started as you need the col air flowing through the Venturi to cause the effect, I have a Chevette with a single Weber 40DCOE which was a absolute nightmare on frosty mornings, it would start on the button but within about 5 minutes of...
by Simon_Admin
Thu Nov 30, 2017 11:14 am
Forum: Technical Questions & Answers
Topic: Head light problem
Replies: 5
Views: 110

Re: Head light problem

Good to hear u fixed it !

Electrical faults can be a right nightmare, especially on plastic cars !
by Simon_Admin
Fri Nov 24, 2017 2:09 pm
Forum: Technical Questions & Answers
Topic: Head light problem
Replies: 5
Views: 110

Re: Head light problem

Hey Bill, If you have both filaments on at the same time It's probably a missing ground so the current is going though dip & main filaments to ground via the other headlamp's main filament - hence why when you take the other lamp out it goes off. Assuming you have the standard mk2 escort loom there ...
by Simon_Admin
Mon Nov 13, 2017 12:51 pm
Forum: Technical Questions & Answers
Topic: A problem?
Replies: 9
Views: 262

Re: A problem?

No Problem - After using photobucket for years because it supported 3rd party linking it was somewhat outraged to find they now want $400 pa. It's very short cited but I for one haven't got time to shift all my photos to another service and then spend hours updating links on all manner of fori !